i-Ready has confirmed that they are fully operational, and loading issues for students have been resolved.
Posted Dec 03, 2025 - 10:02 PST
Monitoring
A fix has been released, and the i-Ready team is actively monitoring the system to confirm the issue has been fully resolved. We will provide further updates if necessary. Thank you for your patience.
Posted Dec 03, 2025 - 08:20 PST
Investigating
We are aware that the loading issue impacting some Grade 6+ students has reoccurred today. Our team is actively investigating and working to restore full functionality. Thank you for your continued patience.
Posted Dec 02, 2025 - 08:12 PST
Monitoring
The i-Ready team has confirmed that i-Ready functionality has been restored. They are actively monitoring the system to confirm the issue has been fully resolved and will provide further updates if necessary. Thank you for your patience.
Posted Dec 01, 2025 - 16:27 PST
Investigating
The i-Ready Team is currently investigating reports of loading issues for students. Our team is actively working to identify the cause and will share updates as soon as more information is available.