LODI UNIFIED SCHOOL DISTRICT

Jive / GoToConnect at Tokay High

Incident Report for LodiUSD Status Page

Update

We are continuing to investigate this issue.
Posted Dec 03, 2025 - 09:05 PST

Investigating

We are currently investigating this issue.
Posted Dec 02, 2025 - 09:31 PST
This incident affects: Common Resources (Jive PBX Service).