LODI UNIFIED SCHOOL DISTRICT

Missing Microsoft 365 apps in Outlook on the web

Incident Report for LodiUSD Status Page

Identified

Microsoft has identified the issue and is preparing to roll out a fix, but has not published a timeline for the deployment.
Posted Dec 15, 2025 - 08:54 PST

Investigating

Some users may be unable to access Microsoft 365 apps through the app launcher in Outlook on the web. Microsoft is aware of the issue and is developing a fix.
Posted Dec 11, 2025 - 08:23 PST
This incident affects: Primary Resources (Office 365).